[US & EU] Notetakers Failing to Join Zoom & Google Meet

Incident Report for Nylas v3

Resolved

Oxylabs has fully restored their services, and we are seeing join rates returning to normal levels. We will continue to monitor closely, and working with Oxylabs to ensure this does not happen in the future. Thank you for your patience during this incident.

If you have any further questions or concerns, please contact support@nylas.com.
Posted May 20, 2026 - 09:49 PDT

Monitoring

We have deployed mitigation steps while we wait on Oxylabs, and join rates are improving once again. We will continue to monitor and post updates as available.
Posted May 20, 2026 - 09:20 PDT

Identified

Starting at approximately 8:59 AM PT, our 3rd party provider Oxylabs experienced an outage that is preventing Nylas Notetakers from joining some Zoom and Google Meet meetings. We are working with the provider and deploying internal mitigation steps now
Posted May 20, 2026 - 09:00 PDT
This incident affected: Nylas Application Services (Notetaker) and 3rd Party Providers (Oxylabs).