US – Service Degradation: Elevated Webhook Latencies Primarily Affecting Microsoft Accounts

Incident Report for Nylas v3

Resolved

Sync and webhook latencies in our US data center remain at normal levels, and the backlog of pending webhook deliveries has been fully cleared.

Our engineering team will continue to monitor for stability, but no further impact is expected.

Thank you for your patience throughout this incident.
Posted Sep 09, 2025 - 15:48 PDT

Update

Sync and webhook latencies in our US data center have returned to normal levels. The backlog of pending webhook deliveries is expected to clear over the next few hours, and we will post an update once this process is complete.

Our engineering team will continue to monitor closely to ensure stability, but no further impact is expected at this time.

Thank you for your patience while we worked to resolve this issue.
Posted Sep 09, 2025 - 14:08 PDT

Monitoring

Sync and webhook latencies are improving. We are continuing to investigate the root cause and are working to ensure performance remains stable.
Posted Sep 09, 2025 - 13:30 PDT

Investigating

We are investigating elevated sync and webhook latencies in our US data center, primarily impacting Microsoft-connected accounts, with some impact also observed on Google accounts.

Our engineering team is analyzing the issue and working to identify the root cause. We will share further updates as more information becomes available.

Thank you for your patience.
Posted Sep 09, 2025 - 12:55 PDT
This incident affected: 3rd Party Providers (Microsoft 365, Google) and Nylas Application Services (Webhooks v3).