Scheduler booking pages not loading for some users or browsers

Incident Report for Nylas v3

Resolved

The incident affecting Scheduler booking pages has been resolved. As of September 10, 2025, at 14:55 PDT / 17:55 EST, booking pages are loading as expected. Please note that the resolution occurred at the time specified above, and this update is being posted retrospectively.
Posted Sep 10, 2025 - 22:14 PDT

Investigating

We are investigating reports that Scheduler booking pages are not loading in some browsers for some users.
Posted Sep 10, 2025 - 14:54 PDT