Correction: Ongoing Incident - [US & EU][Subprocessor] Elevated 503 Responses Linked to Fastly Disruption

Incident Report for Nylas v3

Resolved

Between 2025-04-08 14:00 PDT and 2025-04-08 18:04 PDT, customers may have experienced intermittent 503 errors across our services. This was due to an upstream incident affecting our subprocessor, Fastly.

To mitigate the issue and restore stability, we’ve rerouted impacted traffic from Fastly to Cloudflare. This change has fully resolved the incident.

We’re continuing to monitor closely and will conduct a full postmortem to ensure long-term resilience.
Thank you for your patience
Posted Apr 08, 2025 - 18:40 PDT

Monitoring

We incorrectly marked the earlier incident as resolved. The issue is still ongoing due to a third-party provider, Fastly. We are actively monitoring the situation and assessing any ongoing impact.

We sincerely apologize for the confusion and will post regular updates here as we receive more information
Posted Apr 08, 2025 - 17:00 PDT
This incident affected: Subprocessors (Fastly).