API error rates and latency in the US v3 production environment have returned to normal levels. The mitigation steps implemented earlier have stabilized the system.
We will continue to monitor closely and are implementing additional preventative measures to increase capacity and reduce the risk of recurrence during peak traffic.
Thank you for your patience.
Posted Feb 24, 2026 - 13:25 PST
Monitoring
Mitigation steps have been successfully implemented, and API error rates and latency in the US v3 production environment have returned to normal levels.
We are continuing to closely monitor the environment to ensure stability. We will provide a final update once we confirm the issue is fully resolved.
Posted Feb 24, 2026 - 13:16 PST
Identified
We have identified the underlying issue contributing to elevated API error rates and increased latency in the US v3 production environment. Our engineering team is actively working on mitigation.
Customers may continue to experience intermittent 500 errors and delayed webhooks while mitigation efforts are underway. We will continue to provide updates as progress is made.
Posted Feb 24, 2026 - 12:08 PST
Investigating
We are currently experiencing elevated API error rates and increased latency in the US v3 production environment, affecting a subset of customers. This may result in intermittent 500 errors and delayed webhooks. Our engineering team has identified the issue and is actively working on mitigation. We will continue to share updates here.
Posted Feb 24, 2026 - 11:30 PST
This incident affected: Nylas Application Services (API v3, Webhooks v3).