[US/EU] Elevated Errors for Attachments API Requests on Microsoft Exchange (EWS) Grants

Incident Report for Nylas v3

Update

Error rates have returned to normal levels for /attachment API requests affecting Microsoft Exchange (EWS) grants in both the US and EU regions.

We are continuing to monitor performance to confirm the issue remains fully resolved.
Posted Aug 14, 2026 - 08:02 PDT

Monitoring

Mitigated - We have implemented changes to address the elevated error rates affecting /attachment API requests for Microsoft Exchange (EWS) grants and are seeing recovery.

We are continuing to monitor performance to confirm full recovery across both the US and EU regions.
Posted Aug 14, 2026 - 07:39 PDT

Investigating

We are experiencing elevated error rates for the /attachment API endpoint affecting EWS grants for on-premises and hosted Microsoft Exchange providers in both the US and EU regions. Other grant types, including Microsoft Graph, Google, and IMAP, are not affected.
Posted Aug 14, 2026 - 07:15 PDT
This incident affects: Nylas Application Services (API v3) and 3rd Party Providers (Other Email Server Hosting Providers).