[US] Higher Latency for New and Updated Messages

Incident Report for Nylas v3

Resolved

Sync latencies for new and updated messages in the US region have remained at normal operating levels, and our systems are stable.

The changes implemented during the incident have mitigated the impact of the unusually high notification traffic. We will continue to monitor and address that traffic as part of our normal operations, but it is no longer affecting broader message synchronization performance.

The EU region was not affected. This incident is now resolved. Thank you for your patience while we worked to address this issue.
Posted Aug 11, 2026 - 15:16 PDT

Update

Mitigated - Sync latencies for new and updated messages in the US region have returned to normal operating levels following the infrastructure changes implemented earlier.

We have mitigated the customer impact and are continuing to monitor performance while we investigate the unusually high notification traffic that contributed to the incident.

The EU region remains unaffected.
Posted Aug 11, 2026 - 13:12 PDT

Monitoring

We have observed a large increase in notification traffic from Microsoft Graph today, which resulted in higher latencies for new and updated messages across providers in the US region.

We have made changes to our infrastructure to better handle the increased traffic, and latencies have reduced. We are continuing to monitor performance and investigate the source of the unusually high notification traffic.

The EU region is not affected.
Posted Aug 11, 2026 - 12:53 PDT