[US/EU] Delayed Message Sync and 404 Errors for IMAP-Based Accounts

Incident Report for Nylas v3

Resolved

IMAP synchronization has returned to normal operating levels across the US and EU regions. Our monitoring confirms that affected grants have recovered and previously missed message activity and associated webhooks have been processed.

Customers are no longer affected by this incident.

Thank you for your patience while we worked to address this issue.
Posted Sep 17, 2026 - 07:59 PDT

Update

Mitigated - The remediation has been fully deployed across the US and EU regions, and IMAP synchronization and error rates have returned close to normal operating levels.

Some previously affected grants may still be catching up on messages missed during the incident. We are continuing to monitor recovery closely and validate that synchronization remains stable before resolving the incident.
Posted Sep 17, 2026 - 07:23 PDT

Monitoring

We identified an issue in IMAP message processing that could cause synchronization to stop when certain messages were encountered, resulting in 404 responses when those messages were retrieved by ID.

A remediation has now been fully deployed across the US and EU regions. Message synchronization and success rates are recovering, and we are continuing to validate stability before resolving the incident.
Posted Sep 17, 2026 - 06:48 PDT

Identified

We have identified an issue in IMAP message processing that can cause synchronization to stop when certain messages are encountered, resulting in 404 responses when those messages are retrieved by ID.

Our team is actively working on remediation and validating the appropriate recovery path. We will provide another update as this work progresses and we confirm recovery.
Posted Sep 17, 2026 - 06:03 PDT

Investigating

We are investigating elevated 404 errors when retrieving specific messages via the Messages API for IMAP grants in the US and EU regions. Some messages that exist in the provider mailbox may return a 404 response when retrieved by ID.

Our team is actively investigating the issue and working to restore normal message retrieval. We will provide additional information as it becomes available.
Posted Sep 17, 2026 - 05:31 PDT
This incident affected: Nylas Application Services (API v3, IMAP v3).