Notetakers failing to join some Google Meet events

Incident Report for Nylas v3

Resolved

Notetaker join rates for Google Meet events have returned to normal levels following deployed remediations in response to recent Google changes in production (US and EU). We have confirmed stability with sustained recovery of join rates and are no longer observing elevated failures.
Posted Apr 14, 2026 - 17:20 PDT

Monitoring

We have made improvements and Notetakers are joining correctly. We are continuing to monitor the Notetakers to ensure they continue to operate correctly.
Posted Apr 14, 2026 - 11:28 PDT

Investigating

We are currently investigating an issue where some Nylas Notetakers are not correctly joining Google Meet events. This does not appear to affect other meeting providers or any other parts of the API.
Posted Apr 14, 2026 - 08:19 PDT
This incident affected: 3rd Party Providers (Google) and Nylas Application Services (Notetaker).