All planned changes for this maintenance have been completed. We are currently verifying system stability and monitoring closely before closing the maintenance window. Further updates will be shared here as needed.
Posted Aug 23, 2025 - 09:44 PDT
Update
Between 8:10–8:30 AM PT, we observed a low volume of unexpected "500 Internal Server Errors". Our systems are currently stable, and we will provide any further updates here as needed.
Posted Aug 23, 2025 - 09:02 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2025 - 08:00 PDT
Scheduled
On Saturday August 23rd between 8:00-11:00 AM PT, Nylas will perform scheduled maintenance to upgrade our IMAP High Speed Cache to improve performance and reliability. During this window, customers may experience up to 20 minutes of delays in IMAP sync and webhook delivery. In addition, some duplicate webhooks may be sent during this period. No customer action is required, and impact is expected to be low aside from these temporary delays and duplicate webhooks.