High number of 504 API errors for EWS grants

Incident Report for Nylas v3

Resolved

We have deployed fixes to reduce the excessive 504 errors. They have returned to normal errors.
Posted May 04, 2026 - 08:25 PDT

Investigating

We are currently investigating an increase in 504 API errors for EWS (Exchange on-premise) grants. Grants connected to other providers are not affected.
Posted May 04, 2026 - 07:03 PDT
This incident affected: Nylas Application Services (API v3).