US - Gmail Realtime - Pub/Sub - Elevated Latency & Delayed Webhooks

Incident Report for Nylas v3

Resolved

We have updated our systems and webhooks have returned to normal
Posted May 06, 2026 - 09:39 PDT

Monitoring

We are currently investigating elevated latency affecting Gmail realtime (Pub/Sub) event delivery in the US region. Customers may experience delayed webhooks notifications.

The issue was initially caused by an expired SSL certificate, which has since been addressed. However, the system has not fully recovered and latency remains elevated.

We will provide an update soon.
Posted May 06, 2026 - 08:28 PDT
This incident affected: Nylas Application Services (Webhooks v3).