All services have returned to normal operations, and webhook latency and delivery volume have returned to expected levels. All affected webhooks were successfully recovered and delivered.
Thank you for your patience while we worked to address this issue.
Posted Aug 19, 2026 - 14:34 PDT
Monitoring
Mitigated - We have recovered all affected grants, and webhook delivery has returned to normal levels.
Some previously delayed messages are still being processed, and we are closely monitoring the remaining backlog to ensure delivery completes successfully.
Posted Aug 19, 2026 - 13:20 PDT
Update
We are continuing to work on restoring webhook delivery for affected grants.
We will provide another update as recovery progresses.
Posted Aug 19, 2026 - 11:01 PDT
Identified
We are working to deploy a fix for the issue causing missing or delayed webhooks across providers in the US and EU regions.
We will provide another update as this work progresses.
Posted Aug 19, 2026 - 10:26 PDT
Update
We are continuing to investigate missing or delayed webhooks. Based on our investigation, we have expanded the scope of the issue to include all providers in both the US and EU regions.
We will provide another update as our investigation progresses.
Posted Aug 19, 2026 - 10:00 PDT
Investigating
We are investigating an issue with missing or delayed webhooks for Microsoft and Google grants in the US region.
EU region and all IMAP and EWS grants for both regions are working correctly.
Posted Aug 19, 2026 - 09:11 PDT
This incident affected: Nylas Application Services (Webhooks v3).