EU API seeing increased timeouts and 502s when sending

Incident Report for Nylas v3

Resolved

The issue affecting the send endpoint has been resolved.
All systems are now functioning normally.

Thank you for your understanding.
Posted Jun 24, 2025 - 08:04 PDT

Monitoring

We have addressed the issue with sending delays and errors. We are monitoring our API to ensure things return to normal.
Posted Jun 24, 2025 - 07:28 PDT

Investigating

We are currently investigating reports of increased timeouts, delays, and 502 errors when sending emails through the Nylas API. This appears limited to the EU region, not US.
Posted Jun 24, 2025 - 06:10 PDT