Following our last update, timeout rates continued to improve but had not fully returned to normal. We submitted a support ticket with OVHcloud and escalated it to the highest priority.
While we have not yet received a response or confirmation of resolution from OVHcloud support, all relevant metrics have now returned to normal levels on our side.
We will continue to monitor closely. Once OVHcloud confirms the issue is fully resolved, we will mark this incident as resolved as well.
Posted May 05, 2025 - 12:48 PDT
Update
As part of their incident mitigation efforts, OVHcloud appears to have made significant changes to their DNS records. In response, we cleared all relevant DNS caches and restarted our servers to ensure the most up-to-date routing information is in use.
Since these changes, IMAP connectivity has largely stabilized and timeout rates have decreased overall. However, we are still actively tuning connectivity to certain OVHcloud servers and will continue monitoring closely.
Posted Apr 30, 2025 - 10:42 PDT
Update
OVHcloud has reported that the network incident impacting their Madrid and Paris points of presence has been resolved.
Start Time: April 28, 2025, at 8:08 AM PT End Time: April 28, 2025, at 3:00 PM PT Root Cause: Regional power outage affecting Spain and Portugal.
While OVHcloud has closed their incident, we continue to observe occasional IMAP timeouts. We are closely monitoring the situation and will provide further updates if necessary.
Thank you for your continued patience and understanding.
Posted Apr 29, 2025 - 08:35 PDT
Update
OVHcloud has provided an update on their ongoing incident. Their Madrid Point of Presence (PoP) became accessible again at approximately 2:40 PM Pacific Time. However, they are still experiencing peering issues, which may continue to impact connectivity.
The provider’s teams are actively working to fully restore service. We are continuing to monitor the situation and any potential impacts to IMAP connectivity. Further updates will be posted here as we learn more.
We appreciate your patience and understanding.
Posted Apr 28, 2025 - 15:55 PDT
Monitoring
Starting at approximately 1:30 AM Pacific Time, we began observing elevated timeouts when connecting to the third-party IMAP provider, OVHcloud. OVHcloud has reported an active incident related to widespread power outages across Peninsular Spain and other regions.
We are actively monitoring this situation and any related impacts on email service providers. Updates will be posted here as more information becomes available.
Posted Apr 28, 2025 - 09:00 PDT
This incident affects: 3rd Party Providers (Other Email Server Hosting Providers).