Increased Webhook Delays for Graph Calendar/Contacts/Email and Google Calendar

Incident Report for Nylas v3

Resolved

The incident has been resolved. Thank you for your patience and understanding.
Posted Jul 17, 2024 - 15:54 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 15:40 PDT

Update

We are continuing to investigate this issue. We will post our next update in 1 hour.
Posted Jul 17, 2024 - 14:25 PDT

Update

We are continuing to investigate this issue. We will post our next update in 1 hour.
Posted Jul 17, 2024 - 12:20 PDT

Update

We are continuing to investigate this issue.
Posted Jul 17, 2024 - 11:46 PDT

Update

We are continuing to investigate this issue. The only impact is a delay in webhooks, with a maximum delay of up to 10 minutes.
Posted Jul 17, 2024 - 11:04 PDT

Investigating

We are currently investigating an issue that is causing increased webhook delays for Graph Calendar, Contacts, Email, and Google Calendar services.

There will be increased webhook delays, but we are still sending all webhooks.
Posted Jul 17, 2024 - 10:30 PDT
This incident affected: Nylas Application Services (Webhooks v3).