[US][Low Impact] Webhook Timeout and Send API Degradation
Incident Report for Nylas V3
Resolved
The fix has been successfully deployed.
Posted Jan 23, 2025 - 08:47 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 22, 2025 - 16:15 PST
Monitoring
A transient issue on Nylas infrastructure is causing a small percentage of webhooks to appear as timed out.
We have identified the problem and are working on a fix. In the meantime, keep in mind, these Webhooks will be retried automatically and impact is low.
The same issue is slightly decreasing Send API success rate and slightly increasing sync latencies

We apologize for the inconvenience and appreciate your patience. If you have any questions or concerns, please contact our support team (support@nylas.com).
Posted Jan 22, 2025 - 16:15 PST
This incident affected: Nylas Application Services (API v3, Webhooks v3).